ChiefsPlanet Mobile
Page 2 of 2
< 12
Media Center>What's everyone using for an Antivirus these days?
Buehler445 07:33 AM 12-05-2018
Years ago I put on Avast because it was:
1. Free
2. Light and Low impact.

I'm not sure those 2 things are accurate anymore. What is everyone running these days that won't slog down their rig?
[Reply]
Superturtle 08:49 AM 12-06-2018
Originally Posted by DJJasonp:
BitDefender seemed ok for the past year I've had it. Didnt bog my system down.
Used that in the past and it seemed to do the job.
[Reply]
Saulbadguy 09:34 AM 12-06-2018
I just use Windows Defender.
[Reply]
DaFace 10:15 AM 12-06-2018
Originally Posted by Saulbadguy:
I just use Windows Defender.
Same here. That plus the common sense not to open sketchy files has never resulted in any issues.
[Reply]
htismaqe 11:49 AM 12-06-2018
The thing about Windows Defender is that you're SUPPOSED to be able to disable it but as with all things Microsoft, it's not that simple.

There's really no need for a 3rd party AV anymore because you're paying a resource penalty to do so. Might as well just use the built-in stuff, it's the MS way.
[Reply]
Fishpicker 11:58 AM 12-06-2018
Originally Posted by Gravedigger:
MalwareBytes and ADW
this
[Reply]
Buehler445 12:16 PM 12-06-2018
Originally Posted by htismaqe:
The thing about Windows Defender is that you're SUPPOSED to be able to disable it but as with all things Microsoft, it's not that simple.

There's really no need for a 3rd party AV anymore because you're paying a resource penalty to do so. Might as well just use the built-in stuff, it's the MS way.
So there isn't any glaring risks of running Windows Defender, right? I'll for sure do that.
[Reply]
htismaqe 12:28 PM 12-06-2018
Originally Posted by Buehler445:
So there isn't any glaring risks of running Windows Defender, right? I'll for sure do that.
Not really. I have 4 users here that aren't computer whiz kids by any means (including my mother in law, FWIW) and have never had a virus issue here. I've been using WD/WSE on their machines going back probably 5 or 6 years now.
[Reply]
Buehler445 01:13 PM 12-06-2018
Originally Posted by htismaqe:
Not really. I have 4 users here that aren't computer whiz kids by any means (including my mother in law, FWIW) and have never had a virus issue here. I've been using WD/WSE on their machines going back probably 5 or 6 years now.
Good news. Thanks.
[Reply]
Page 2 of 2
< 12
Up